Raj2796's Blog

January 25, 2011

VMware Template renames network adaptor when deploying windows 7 or windows 2008 R2

Filed under: MS,vmware — raj2796 @ 10:40 am

This caught me out for a while and I originally thought i had made a mistake in creating my templates, however it appears this is a known issue with VMware, from the VMware knowledge base :

Deploying Windows 2008 R2 and Windows 7 templates with vmxnet3 renames the NIC as #2

Symptoms
When deploying virtual machines from a Windows 2008 R2 or Windows 7 template configured with the vmxnet3 Ethernet device, the resulting virtual machine’s guest operating system shows the Ethernet adapter as:

VMXNET Device #2 in Device Manager
Local Area connection #2 in Network Properties

Resolution
This issue occurs when virtual adapter VMXNET3 is used.
To workaround this issue, try one of these options:

  • Use E1000 virtual network cards in Windows 2008 R2 and Windows 7 templates.
  • Apply the Microsoft hotfix for this issue. For more information, see the Microsoft Knowledge Base article 2344941.

This hotfix may resolve issues with duplicate MACs when deploying Windows 2008 R2 from template using an E1000 driver.

Note: The preceding link was correct as of January 12, 2011. If you find the link is broken, provide feedback and a VMware employee will update the link.

From :
http://kb.vmware.com/kb/1020078

Advertisements

Leave a Comment »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: